Creates a new fluid type and adds it to the document.
Namespace: Autodesk.Revit.DB.PlumbingAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2013
Syntax
C# |
---|
public static FluidType Create( Document document, string fluidTypeName, FluidType basedOnFluidType ) |
Visual Basic |
---|
Public Shared Function Create ( _ document As Document, _ fluidTypeName As String, _ basedOnFluidType As FluidType _ ) As FluidType |
Visual C++ |
---|
public: static FluidType^ Create( Document^ document, String^ fluidTypeName, FluidType^ basedOnFluidType ) |
Parameters
- document
- Type: Autodesk.Revit.DB..::..Document
The document.
- fluidTypeName
- Type: System..::..String
The name of new created fluid type.
- basedOnFluidType
- Type: Autodesk.Revit.DB.Plumbing..::..FluidType
The existing fluid type which is based on.
Return Value
The newly created fluid type.
Remarks
The new fluid type will be a duplicate of the input type.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |