Adds intersecting reference with an offset.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:
2013
Syntax
C# |
---|
public bool AddIntersectingReference(
ElementId intersectingReference,
double offset
) |
Visual Basic |
---|
Public Function AddIntersectingReference ( _
intersectingReference As ElementId, _
offset As Double _
) As Boolean |
Visual C++ |
---|
public:
bool AddIntersectingReference(
ElementId^ intersectingReference,
double offset
) |
Parameters
- intersectingReference
- Type: Autodesk.Revit.DB..::..ElementId
Id of the new intersecting reference.
- offset
- Type: System..::..Double
The Offste for the new intersecting reference.
Return Value
True if the PartMaker did not already use this
intersecting reference and it was added, false if the PartMaker
already used this intersecting reference and this call
only updated its offset.
Exceptions
See Also