Gets the id of the EndTreatmentType at the specified rebar shape end.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:  2017

Syntax

C#
public ElementId GetEndTreatmentTypeId(
	int iEnd
)
Visual Basic
Public Function GetEndTreatmentTypeId ( _
	iEnd As Integer _
) As ElementId
Visual C++
public:
ElementId^ GetEndTreatmentTypeId(
	int iEnd
)

Parameters

iEnd
Type: System..::..Int32
0 for the start end treatment, 1 for the end end treatment.

Return Value

Returns the id of an EndTreatmentType, or invalidElementId if the rebar shape has no end treatment at the specified end.

Exceptions

ExceptionCondition
Autodesk.Revit.Exceptions..::..ArgumentException iEnd not a valid shape end

See Also