Gets fabrication connector identifiers from the fabrication configuration, filtered by shape and domain.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2016
Syntax
C# |
---|
public IList<int> GetAllFabricationConnectorDefinitions( ConnectorDomainType domain, ConnectorProfileType shape ) |
Visual Basic |
---|
Public Function GetAllFabricationConnectorDefinitions ( _ domain As ConnectorDomainType, _ shape As ConnectorProfileType _ ) As IList(Of Integer) |
Visual C++ |
---|
public: IList<int>^ GetAllFabricationConnectorDefinitions( ConnectorDomainType domain, ConnectorProfileType shape ) |
Parameters
- domain
- Type: Autodesk.Revit.DB..::..ConnectorDomainType
ConnectorDomainType to filter by. Pass ConnectorDomainType.Undefined to get all connector domains.
- shape
- Type: Autodesk.Revit.DB..::..ConnectorProfileType
ConnectorProfileType to filter by. Pass ConnectorProfileType.Invalid to get all shapes.
Return Value
All the fabrication connector identifiers, filtered by shape and domain. The return will be empty if no connectors are found.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |