Validates that the given DirectShapeOptions are allowed for this particular DirectShape.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2016
Syntax
C# |
---|
public bool AreOptionsValid( DirectShapeOptions options ) |
Visual Basic |
---|
Public Function AreOptionsValid ( _ options As DirectShapeOptions _ ) As Boolean |
Visual C++ |
---|
public: bool AreOptionsValid( DirectShapeOptions^ options ) |
Parameters
- options
- Type: Autodesk.Revit.DB..::..DirectShapeOptions
The options object.
Return Value
True if the DirectShapeOptions are valid; false otherwise.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |