This class is used to control behavior of a DirectShape object.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2016
Syntax
C# |
---|
public class DirectShapeOptions : IDisposable |
Visual Basic |
---|
Public Class DirectShapeOptions _ Implements IDisposable |
Visual C++ |
---|
public ref class DirectShapeOptions : IDisposable |
Remarks
Use Enable/Disable functions to change the default behavior.
Use DirectShape.SetOptions to modify that object's behavior.
Inheritance Hierarchy
System..::..Object
Autodesk.Revit.DB..::..DirectShapeOptions
Autodesk.Revit.DB..::..DirectShapeOptions