Check if the updater is optional or not.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2011
Syntax
C# |
---|
public static bool GetIsUpdaterOptional( UpdaterId id ) |
Visual Basic |
---|
Public Shared Function GetIsUpdaterOptional ( _ id As UpdaterId _ ) As Boolean |
Visual C++ |
---|
public: static bool GetIsUpdaterOptional( UpdaterId^ id ) |
Parameters
- id
- Type: Autodesk.Revit.DB..::..UpdaterId
Id of the updater to check
Return Value
Returns True if the updater is optional, False otherwise.
Remarks
This flag controls whether an updater is going to be required next time a document in which
it had been used is opened. If a non-optional updater is not found (currently not registered)
in a document, the end user will be presented with a warning and choices to resolve
the situation.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | Updater with this Id is not currently registered in Revit. |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |