Checks if the dimension style can be used with multi-reference annotations.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2014
Syntax
C# |
---|
public bool IsAllowedDimensionStyle( ElementId dimensionStyleId ) |
Visual Basic |
---|
Public Function IsAllowedDimensionStyle ( _ dimensionStyleId As ElementId _ ) As Boolean |
Visual C++ |
---|
public: bool IsAllowedDimensionStyle( ElementId^ dimensionStyleId ) |
Parameters
- dimensionStyleId
- Type: Autodesk.Revit.DB..::..ElementId
The dimension style to check.
Return Value
True if the dimension style can be used by multi-reference annotations.
Remarks
Only linear dimension styles are allowed.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |