Create a constraint to drive sagitta length.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2012
Syntax
C# |
---|
public RebarShapeConstraintSagittaLength( ElementId paramId ) |
Visual Basic |
---|
Public Sub New ( _ paramId As ElementId _ ) |
Visual C++ |
---|
public: RebarShapeConstraintSagittaLength( ElementId^ paramId ) |
Parameters
- paramId
- Type: Autodesk.Revit.DB..::..ElementId
The Id of a Rebar Shape parameter.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | paramId is not a valid Element identifier. |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |