Sets the spatial element boundary location of a spatial element type.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2014
Syntax
C# |
---|
public void SetSpatialElementBoundaryLocation( SpatialElementBoundaryLocation spatialElementBoundaryLocation, SpatialElementType spType ) |
Visual Basic |
---|
Public Sub SetSpatialElementBoundaryLocation ( _ spatialElementBoundaryLocation As SpatialElementBoundaryLocation, _ spType As SpatialElementType _ ) |
Visual C++ |
---|
public: void SetSpatialElementBoundaryLocation( SpatialElementBoundaryLocation spatialElementBoundaryLocation, SpatialElementType spType ) |
Parameters
- spatialElementBoundaryLocation
- Type: Autodesk.Revit.DB..::..SpatialElementBoundaryLocation
The boundary location.
- spType
- Type: Autodesk.Revit.DB..::..SpatialElementType
The spatial element type.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | Currently only SpatialElementType.Room is permitted when setting the boundary location. |
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |