Zoom and center the view to a specified rectangle.
Namespace: Autodesk.Revit.UIAssembly: RevitAPIUI (in RevitAPIUI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2013
Syntax
C# |
---|
public void ZoomAndCenterRectangle( XYZ viewCorner1, XYZ viewCorner2 ) |
Visual Basic |
---|
Public Sub ZoomAndCenterRectangle ( _ viewCorner1 As XYZ, _ viewCorner2 As XYZ _ ) |
Visual C++ |
---|
public: void ZoomAndCenterRectangle( XYZ^ viewCorner1, XYZ^ viewCorner2 ) |
Parameters
- viewCorner1
- Type: Autodesk.Revit.DB..::..XYZ
A corner of the desired view rectangle in model coordinates.
- viewCorner2
- Type: Autodesk.Revit.DB..::..XYZ
The opposite corner of the desired view rectangle in model coordinates.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |