The direction of the RebarShapeSegment in UV-space.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:  2012

Syntax

C#
public UV Direction { get; set; }
Visual Basic
Public Property Direction As UV
	Get
	Set
Visual C++
public:
property UV^ Direction {
	UV^ get ();
	void set (UV^ value);
}

Exceptions

ExceptionCondition
Autodesk.Revit.Exceptions..::..ArgumentNullException When setting this property: A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..DisabledDisciplineException When setting this property: None of the following disciplines is enabled: Structural.

See Also