The error level that the routing preference manager should post errors if the routing conditions do not meet any routing preference rule, could be None, Warning, or Error
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2013
Syntax
C# |
---|
public RoutingPreferenceErrorLevel ErrorLevel { get; set; } |
Visual Basic |
---|
Public Property ErrorLevel As RoutingPreferenceErrorLevel Get Set |
Visual C++ |
---|
public: property RoutingPreferenceErrorLevel ErrorLevel { RoutingPreferenceErrorLevel get (); void set (RoutingPreferenceErrorLevel value); } |
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration |
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | When setting this property: None of the following disciplines is enabled: Mechanical Electrical Piping. |