An enumerated type listing the options for posting errors or warnings when routing preferences are not satisfied.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2013
Since: 2013
Syntax
C# |
---|
public enum RoutingPreferenceErrorLevel |
Visual Basic |
---|
Public Enumeration RoutingPreferenceErrorLevel |
Visual C++ |
---|
public enum class RoutingPreferenceErrorLevel |
Members
Member name | Description |
---|---|
None | Do not post any warning or error if there is no rule in the routing preference satisfying the current condition. |
Warning | Post Revit warnings if there is no rule in the routing preference satisfying the current condition. |
Error | Post Revit errors if there is no rule in the routing preference satisfying the current condition. |