The fabric sheet alignment in the fabric distribution in the major direction.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2013
Syntax
C# |
---|
public FabricSheetAlignment MajorSheetAlignment { get; set; } |
Visual Basic |
---|
Public Property MajorSheetAlignment As FabricSheetAlignment Get Set |
Visual C++ |
---|
public: property FabricSheetAlignment MajorSheetAlignment { FabricSheetAlignment get (); void set (FabricSheetAlignment value); } |
Remarks
Changing the value of this property causes change of MajorLapSplice and LapSplicePosition properties if needed
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration |
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | When setting this property: None of the following disciplines is enabled: Structural. |