Creates an empty face in the geometry being built. Other BRepBuilder methods are used to add loops to the face.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:
2016
Syntax
Parameters
- surfaceGeom
- Type: Autodesk.Revit.DB..::..BRepBuilderSurfaceGeometry
The face's support surface.
- bFaceIsReversed
- Type: System..::..Boolean
True if the face's orientation is opposite to that of the surface, false if the orientations agree.
The faces of each shell must be consistently oriented. For a solid (BRepType == Solid), the oriented face normals
must point out of the solid; for a void (BRepType == Void), the face normals must point into the void.
See the description of the bCoEdgeIsReversed input for AddCoEdge() for a discussion of the loop and co-edge orientation conventions
to use with the BRepBuilder.
Return Value
An id that can be used to identify the face while the BRepBuilder is actively building geometry (e.g., to add a loop to a face).
Exceptions
See Also