This class is used by the BRepBuilder class to identify objects it creates (faces, edges, etc.).
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2016
Syntax
C# |
---|
public class BRepBuilderGeometryId : IDisposable |
Visual Basic |
---|
Public Class BRepBuilderGeometryId _ Implements IDisposable |
Visual C++ |
---|
public ref class BRepBuilderGeometryId : IDisposable |
Remarks
The user should use these ids to organize the calls to BRepBuilder methods (e.g., addLoop() takes a face id as input,
referring to a face that was previously added by a call to AddFace()). The ids are only valid while the BRepBuilder is in use.
Inheritance Hierarchy
System..::..Object
Autodesk.Revit.DB..::..BRepBuilderGeometryId
Autodesk.Revit.DB..::..BRepBuilderGeometryId