Retrieves the electrical systems this electrical panel currently is assigned to.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
[ObsoleteAttribute("This property is deprecated in Revit 2021. Use GetAssignedElectricalSystems() method instead, which returns a standard .NET collection.")] public ElectricalSystemSet AssignedElectricalSystems { get; } |
Visual Basic |
---|
<ObsoleteAttribute("This property is deprecated in Revit 2021. Use GetAssignedElectricalSystems() method instead, which returns a standard .NET collection.")> _ Public ReadOnly Property AssignedElectricalSystems As ElectricalSystemSet Get |
Visual C++ |
---|
[ObsoleteAttribute(L"This property is deprecated in Revit 2021. Use GetAssignedElectricalSystems() method instead, which returns a standard .NET collection.")] public: property ElectricalSystemSet^ AssignedElectricalSystems { ElectricalSystemSet^ get (); } |
Remarks
This property returns a set of Electrical Systems. If there are no electrical systems created
for this model, this property will be an empty set.