Finishes the edit scope.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2014
Syntax
C# |
---|
public void Commit( IFailuresPreprocessor failurePreprocessor ) |
Visual Basic |
---|
Public Sub Commit ( _ failurePreprocessor As IFailuresPreprocessor _ ) |
Visual C++ |
---|
public: void Commit( IFailuresPreprocessor^ failurePreprocessor ) |
Parameters
- failurePreprocessor
- Type: Autodesk.Revit.DB..::..IFailuresPreprocessor
Callback to be invoked in the beginning of failure processing.
Remarks
All the changes made after starting the EditScope will be committed. Changes will be merged into one transaction.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions..::..InvalidOperationException | EditScope is not active. EditScope can only be committed or cancelled when it is active. -or- EditScope cannot be closed, for there is a transaction or transaction group still open in the document. |