The base class for a scope object that provides special access and limitations related to editing certain elements.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2014
Syntax
C# |
---|
public class EditScope : IDisposable |
Visual Basic |
---|
Public Class EditScope _ Implements IDisposable |
Visual C++ |
---|
public ref class EditScope : IDisposable |
Remarks
Derivations of this class provide specific functionality to manage edit modes for specific purposes.
Inheritance Hierarchy
System..::..Object
Autodesk.Revit.DB..::..EditScope
Autodesk.Revit.DB.Architecture..::..TopographyEditScope
Autodesk.Revit.DB..::..StairsEditScope
Autodesk.Revit.DB..::..EditScope
Autodesk.Revit.DB.Architecture..::..TopographyEditScope
Autodesk.Revit.DB..::..StairsEditScope