Constructs a new ImagePlacementOptions for placing an ImageInstance
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2020
Syntax
C# |
---|
public ImagePlacementOptions( XYZ location, BoxPlacement placementPoint ) |
Visual Basic |
---|
Public Sub New ( _ location As XYZ, _ placementPoint As BoxPlacement _ ) |
Visual C++ |
---|
public: ImagePlacementOptions( XYZ^ location, BoxPlacement placementPoint ) |
Parameters
- location
- Type: Autodesk.Revit.DB..::..XYZ
The location where the image will be placed
- placementPoint
- Type: Autodesk.Revit.DB..::..BoxPlacement
The point of the image that will be aligned to the location in the view
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |