The alternate units display mode for this DimensionType.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public AlternateUnits AlternateUnits { get; set; } |
Visual Basic |
---|
Public Property AlternateUnits As AlternateUnits Get Set |
Visual C++ |
---|
public: property AlternateUnits AlternateUnits { AlternateUnits get (); void set (AlternateUnits value); } |
Field Value
Alternate units let dimensions display values in multiple units. For example, for a dimension which shows its values in imperial units, alternate units can be used to repeat those values in metric units.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration |