Sets a flag indicating whether an updater is optional or not.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2011
Syntax
C# |
---|
public static void SetIsUpdaterOptional( UpdaterId id, bool isOptional ) |
Visual Basic |
---|
Public Shared Sub SetIsUpdaterOptional ( _ id As UpdaterId, _ isOptional As Boolean _ ) |
Visual C++ |
---|
public: static void SetIsUpdaterOptional( UpdaterId^ id, bool isOptional ) |
Parameters
- id
- Type: Autodesk.Revit.DB..::..UpdaterId
Id of the updater
- isOptional
- Type: System..::..Boolean
Use True to make the updater optional, false to make it a mandatory updater.
Remarks
This flag controls whether an updater is going to be required next time a document in which
it had been used is opened. If a non-optional updater is not found (currently not registered)
in a document, the end user will be presented with a warning and choices to resolve
the situation.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | Updater with this Id is not currently registered in Revit. |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |