Sets the service group exclusions, used by Route and Fill or Design to Fabrication commands, for the current user and session only. This will alter them from the default configuration exclusions to only exclude those groups passed.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:
2017 Subscription Update
Syntax
C# |
---|
public bool SetServiceGroupExclusions(
IList<int> excludedGroups
) |
Visual Basic |
---|
Public Function SetServiceGroupExclusions ( _
excludedGroups As IList(Of Integer) _
) As Boolean |
Visual C++ |
---|
public:
bool SetServiceGroupExclusions(
IList<int>^ excludedGroups
) |
Parameters
- excludedGroups
- Type: System.Collections.Generic..::..IList<(Of <(<'Int32>)>)>
A list of service group indexes to be excluded.
Return Value
Returns true if succeeded to set the exclusions to the specified group(s).
Exceptions
See Also