Implement this method to return an iterator for iterating over blocks of this point cloud.
Namespace: Autodesk.Revit.DB.PointCloudsAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2013
Syntax
C# |
---|
IPointSetIterator CreatePointSetIterator( PointCloudFilter rFilter, double density, ElementId viewId ) |
Visual Basic |
---|
Function CreatePointSetIterator ( _ rFilter As PointCloudFilter, _ density As Double, _ viewId As ElementId _ ) As IPointSetIterator |
Visual C++ |
---|
IPointSetIterator^ CreatePointSetIterator( PointCloudFilter^ rFilter, double density, ElementId^ viewId ) |
Parameters
- rFilter
- Type: Autodesk.Revit.DB.PointClouds..::..PointCloudFilter
The filter used to process cloud points and determine which ones lie with the target volume.
- density
- Type: System..::..Double
Desired number of points per unit area. Area is computed in native units of the point cloud. Another iterator, created with the same density and a more restrictive filter, should return a subset of the points returned by this iterator.
- viewId
- Type: Autodesk.Revit.DB..::..ElementId
The view id for the current view passed as auxiliary information to allow the engine to optimize retrieval of points. If viewId == InvalidElementId, the query is not for a view display operation.