This method is called after unhandled curve was tessellated to polyline segments and sent to the output.
Namespace: Autodesk.Revit.DBNote for 2D export: if the export is performed for the view in non-Wireframe display style, then
- this method is called outside of view, instance and link begin/end calls but still between OnElementBegin2D/OnElementEnd2D calls
- this method is never called for annotation elements, i.e. their geometry should be processed in methods OnCurve and OnPolyline
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
void OnPolylineSegments( PolylineSegments segments ) |
Visual Basic |
---|
Sub OnPolylineSegments ( _ segments As PolylineSegments _ ) |
Visual C++ |
---|
void OnPolylineSegments( PolylineSegments^ segments ) |
Parameters
- segments
- Type: Autodesk.Revit.DB..::..PolylineSegments
A structure describing the polyline segments.