Returns the location of one of the points of the ImageInstance
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2020
Syntax
C# |
---|
public XYZ GetLocation( BoxPlacement placementPoint ) |
Visual Basic |
---|
Public Function GetLocation ( _ placementPoint As BoxPlacement _ ) As XYZ |
Visual C++ |
---|
public: XYZ^ GetLocation( BoxPlacement placementPoint ) |
Parameters
- placementPoint
- Type: Autodesk.Revit.DB..::..BoxPlacement
The placementPoint specifies for which point of the ImageInstance the location should be returned.
Return Value
The location of the specified point
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |