Scales the linear part of this transformation and returns the result.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2021
Syntax
C# |
---|
public Transform2D PreScale( double scale ) |
Visual Basic |
---|
Public Function PreScale ( _ scale As Double _ ) As Transform2D |
Visual C++ |
---|
public: Transform2D^ PreScale( double scale ) |
Parameters
- scale
- Type: System..::..Double
The scale value.
Return Value
Returns a pointer to "this" Transform2D.
Remarks
The resulting transformation is equivalent to the application of the uniform scale and then this transformation, in this order.