Constructs a new instance of an SelectableInViewFilter.
Namespace: Autodesk.Revit.UI.SelectionAssembly: RevitAPIUI (in RevitAPIUI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2015
Syntax
C# |
---|
public SelectableInViewFilter( Document document, ElementId viewId ) |
Visual Basic |
---|
Public Sub New ( _ document As Document, _ viewId As ElementId _ ) |
Visual C++ |
---|
public: SelectableInViewFilter( Document^ document, ElementId^ viewId ) |
Parameters
- document
- Type: Autodesk.Revit.DB..::..Document
The document that owns the view.
- viewId
- Type: Autodesk.Revit.DB..::..ElementId
The view id.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | viewId is not a view. -or- viewId is not valid for element iteration, because it has no way of representing drawn elements. Many view templates will fail this check. |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |