Returns all elements of which properties are driven by this global parameter.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2016 Subscription Update
Syntax
C# |
---|
public ISet<ElementId> GetAffectedElements() |
Visual Basic |
---|
Public Function GetAffectedElements As ISet(Of ElementId) |
Visual C++ |
---|
public: ISet<ElementId^>^ GetAffectedElements() |
Return Value
Collection of Element Ids.
Remarks
The returned collection does not include dimensions labeled by this global parameter.
To get the labeled dimensions use the GetLabeledDimensions()()()() method.
Other global parameters that may be affected by this one (in their formulas)
are also excluded from the returned collection. To get the set of affected global
parameters use the GetAffectedGlobalParameters()()()() method.