Returns all dimension elements that are currently labeled by this global parameter.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2016 Subscription Update
Syntax
C# |
---|
public ISet<ElementId> GetLabeledDimensions() |
Visual Basic |
---|
Public Function GetLabeledDimensions As ISet(Of ElementId) |
Visual C++ |
---|
public: ISet<ElementId^>^ GetLabeledDimensions() |
Return Value
Collection of Element Ids.
Remarks
In case of a reporting parameter the returned collection will contain
at most one element - the driving dimension, if it has been set already.
It is because reporting parameters may have only one dimension labeled.
For non-reporting parameters the set would contain all dimensions that
have been labeled by this global parameter.