Determines if the inputs are valid, and returns an error message if not.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2014
Syntax
C# |
---|
bool ValidateExportOptions( Document document, string folder, string name, NavisworksExportOptions options, out string exceptionMessage ) |
Visual Basic |
---|
Function ValidateExportOptions ( _ document As Document, _ folder As String, _ name As String, _ options As NavisworksExportOptions, _ <OutAttribute> ByRef exceptionMessage As String _ ) As Boolean |
Visual C++ |
---|
bool ValidateExportOptions( Document^ document, String^ folder, String^ name, NavisworksExportOptions^ options, [OutAttribute] String^% exceptionMessage ) |
Parameters
- document
- Type: Autodesk.Revit.DB..::..Document
The document to export.
- folder
- Type: System..::..String
The folder path.
- name
- Type: System..::..String
The file name.
- options
- Type: Autodesk.Revit.DB..::..NavisworksExportOptions
The export options.
- exceptionMessage
- Type: System..::..String%
The message to show in the exception thrown. This is not an end-user visible message, it is a developer message, and does not have to be localized. Ignored if the function returns true.