Retrieves the GUID representing the subelement in DWF and IFC export.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2018
Syntax
C# |
---|
public static Guid GetExportId( Subelement subelement ) |
Visual Basic |
---|
Public Shared Function GetExportId ( _ subelement As Subelement _ ) As Guid |
Visual C++ |
---|
public: static Guid GetExportId( Subelement^ subelement ) |
Parameters
- subelement
- Type: Autodesk.Revit.DB..::..Subelement
The subelement.
Return Value
The value of the GUID representing the subelement in the export context.
Remarks
This id is used in the contents of DWF export and IFC export and it should be used
only when cross-referencing to the contents of these export formats.
When storing Ids that will need to be mapped back to subelements in future sessions,
UniqueId must be used.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |