Adds a regular field at the end of the list.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2013
Syntax
C# |
---|
public ScheduleField AddField( ScheduleFieldType fieldType, ElementId parameterId ) |
Visual Basic |
---|
Public Function AddField ( _ fieldType As ScheduleFieldType, _ parameterId As ElementId _ ) As ScheduleField |
Visual C++ |
---|
public: ScheduleField^ AddField( ScheduleFieldType fieldType, ElementId^ parameterId ) |
Parameters
- fieldType
- Type: Autodesk.Revit.DB..::..ScheduleFieldType
The type of data displayed by the field.
- parameterId
- Type: Autodesk.Revit.DB..::..ElementId
The ID of the parameter displayed by the field.
Return Value
The new field.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |
Autodesk.Revit.Exceptions..::..ArgumentsInconsistentException | The field specified by fieldType and parameterId may not included in this ScheduleDefinition. -or- The field specified by fieldType and parameterId is already included in this ScheduleDefinition. |