Removes an attachment at the top or base of a column, if there is one.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public static void RemoveColumnAttachment( FamilyInstance column, int baseOrTop ) |
Visual Basic |
---|
Public Shared Sub RemoveColumnAttachment ( _ column As FamilyInstance, _ baseOrTop As Integer _ ) |
Visual C++ |
---|
public: static void RemoveColumnAttachment( FamilyInstance^ column, int baseOrTop ) |
Parameters
- column
- Type: Autodesk.Revit.DB..::..FamilyInstance
A column.
- baseOrTop
- Type: System..::..Int32
0 for base, 1 for top.
Remarks
This method modifies both column and target elements.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | baseOrTop must be either 0 or 1. |