An object representing the attachment of the top or bottom of a column to some target:
a floor, roof, ceiling, beam, or brace.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public class ColumnAttachment : IDisposable |
Visual Basic |
---|
Public Class ColumnAttachment _ Implements IDisposable |
Visual C++ |
---|
public ref class ColumnAttachment : IDisposable |
Remarks
Call IsValidColumn() and IsValidTarget() to verify that specific elements support
column attachments. A column has at most one top attachment and one bottom
attachment.
Inheritance Hierarchy
System..::..Object
Autodesk.Revit.DB..::..ColumnAttachment
Autodesk.Revit.DB..::..ColumnAttachment