Reads content from a file of IFC format.
Namespace: Autodesk.Revit.DB.IFCAssembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 21.0.0.0 (21.1.1.109)
Since:
2015
Syntax
C# |
---|
public void Read(
IFCFileReadOptions readOptions,
out int pNumErrors,
out int pNumWarnings
) |
Visual Basic |
---|
Public Sub Read ( _
readOptions As IFCFileReadOptions, _
<OutAttribute> ByRef pNumErrors As Integer, _
<OutAttribute> ByRef pNumWarnings As Integer _
) |
Visual C++ |
---|
public:
void Read(
IFCFileReadOptions^ readOptions,
[OutAttribute] int% pNumErrors,
[OutAttribute] int% pNumWarnings
) |
Parameters
- readOptions
- Type: Autodesk.Revit.DB.IFC..::..IFCFileReadOptions
The IFC file read options.
- pNumErrors
- Type: System..::..Int32%
The number of errors reported during the read process. The actual messages will be in the log file.
- pNumWarnings
- Type: System..::..Int32%
The number of warnings reported during the read process. The actual messages will be in the log file.
Exceptions
See Also