Constructs a new instance of a filter to match elements with a bounding box that is contained by the given Outline.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2011
Syntax
C# |
---|
public BoundingBoxIsInsideFilter( Outline outline ) |
Visual Basic |
---|
Public Sub New ( _ outline As Outline _ ) |
Visual C++ |
---|
public: BoundingBoxIsInsideFilter( Outline^ outline ) |
Parameters
- outline
- Type: Autodesk.Revit.DB..::..Outline
The Outline used to find elements with a bounding box that are contained by it.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | outline is an empty Outline. |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |