A structure that has access to the pen properties of lines/curves
that are currently being drawn/exported via an export context
during a custom export process.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2016
Syntax
C# |
---|
public class LineProperties : IDisposable |
Visual Basic |
---|
Public Class LineProperties _ Implements IDisposable |
Visual C++ |
---|
public ref class LineProperties : IDisposable |
Remarks
For more about using properties of this class refer to the interface
IModelExportContext and its methods
which handle geometric objects such as OnCurve(CurveNode),
OnLineSegment(LineSegment), etc.
LineProperties are available as a read-only property on the respective output nodes,
i.e. CurveNode, LineSegment, etc.
Inheritance Hierarchy
System..::..Object
Autodesk.Revit.DB..::..LineProperties
Autodesk.Revit.DB..::..LineProperties