This method is called after unhandled curve was tessellated to line segments and sent to the output.
Namespace: Autodesk.Revit.DBNote for 2D export: if the export is performed for the view in non-Wireframe display style, then
- this method is called outside of view, instance and link begin/end calls but still between OnElementBegin2D/OnElementEnd2D calls
- this method is never called for annotation elements, i.e. their geometry should be processed in methods OnCurve and OnPolyline
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
void OnLineSegment( LineSegment segment ) |
Visual Basic |
---|
Sub OnLineSegment ( _ segment As LineSegment _ ) |
Visual C++ |
---|
void OnLineSegment( LineSegment^ segment ) |
Parameters
- segment
- Type: Autodesk.Revit.DB..::..LineSegment
A structure describing the line segment.