Get all available parameter categories.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public IList<ElementId> GetAvailableParameterCategories( SectionType sectionType, int row ) |
Visual Basic |
---|
Public Function GetAvailableParameterCategories ( _ sectionType As SectionType, _ row As Integer _ ) As IList(Of ElementId) |
Visual C++ |
---|
public: IList<ElementId^>^ GetAvailableParameterCategories( SectionType sectionType, int row ) |
Parameters
- sectionType
- Type: Autodesk.Revit.DB..::..SectionType
The section the row lies in.
- row
- Type: System..::..Int32
The row.
Return Value
The available parameter categories.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | The sectionType is not a valid type for this view. |
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | The given row number row is invalid. -or- A value passed for an enumeration argument is not a member of that enumeration |