Constructs a ReferenceIntersector which is set to return intersections from all elements and representing all reference target types.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:  2013

Syntax

C#
public ReferenceIntersector(
	View3D view3d
)
Visual Basic
Public Sub New ( _
	view3d As View3D _
)
Visual C++
public:
ReferenceIntersector(
	View3D^ view3d
)

Parameters

view3d
Type: Autodesk.Revit.DB..::..View3D
The view in which to find references.

Exceptions

ExceptionCondition
Autodesk.Revit.Exceptions..::..ArgumentException Returns true if the view is not a view template.
Autodesk.Revit.Exceptions..::..ArgumentNullException A non-optional argument was NULL

See Also