Returns a normal vector at the given index
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2014
Syntax
C# |
---|
public XYZ GetNormal( int idx ) |
Visual Basic |
---|
Public Function GetNormal ( _ idx As Integer _ ) As XYZ |
Visual C++ |
---|
public: XYZ^ GetNormal( int idx ) |
Parameters
- idx
- Type: System..::..Int32
A zero-based index
Return Value
XYZ value representing a normal vector
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | The given value is not a valid index of a normal of the polymesh. A valid valure is not negative and is smaller than the number of normals in the polymesh. |