Creates a new CoverType in the document.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public static RebarCoverType Create( Document doc, string name, double coverDistance ) |
Visual Basic |
---|
Public Shared Function Create ( _ doc As Document, _ name As String, _ coverDistance As Double _ ) As RebarCoverType |
Visual C++ |
---|
public: static RebarCoverType^ Create( Document^ doc, String^ name, double coverDistance ) |
Parameters
- doc
- Type: Autodesk.Revit.DB..::..Document
- name
- Type: System..::..String
- coverDistance
- Type: System..::..Double
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | name is an empty string. |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | coverDistance cannot be negative. |