Sets a cell's style
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public void SetCellStyle(
int nRow,
int nCol,
TableCellStyle Style
) |
Visual Basic |
---|
Public Sub SetCellStyle ( _
nRow As Integer, _
nCol As Integer, _
Style As TableCellStyle _
) |
Visual C++ |
---|
public:
void SetCellStyle(
int nRow,
int nCol,
TableCellStyle^ Style
) |
Remarks
Examples
CopyC#
public void FormatSubtitle(ViewSchedule colSchedule)
{
TableData colTableData = colSchedule.GetTableData();
TableSectionData tsd = colTableData.GetSectionData(SectionType.Header);
if (tsd.AllowOverrideCellStyle(tsd.FirstRowNumber + 1, tsd.FirstColumnNumber))
{
TableCellStyle tcs = new TableCellStyle();
TableCellStyleOverrideOptions options = new TableCellStyleOverrideOptions();
options.FontSize = true;
options.Bold = true;
tcs.SetCellStyleOverrideOptions(options);
tcs.IsFontBold = true;
tcs.TextSize = 10;
tsd.SetCellStyle(tsd.FirstRowNumber + 1, tsd.FirstColumnNumber, tcs);
}
}
CopyVB.NET
Public Sub FormatSubtitle(colSchedule As ViewSchedule)
Dim colTableData As TableData = colSchedule.GetTableData()
Dim tsd As TableSectionData = colTableData.GetSectionData(SectionType.Header)
If tsd.AllowOverrideCellStyle(tsd.FirstRowNumber + 1, tsd.FirstColumnNumber) Then
Dim tcs As New TableCellStyle()
Dim options As New TableCellStyleOverrideOptions()
options.FontSize = True
options.Bold = True
tcs.SetCellStyleOverrideOptions(options)
tcs.IsFontBold = True
tcs.TextSize = 10
tsd.SetCellStyle(tsd.FirstRowNumber + 1, tsd.FirstColumnNumber, tcs)
End If
End Sub
Exceptions
See Also