Checks if the specified layer is a core layer.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public bool IsCoreLayer( int layerIdx ) |
Visual Basic |
---|
Public Function IsCoreLayer ( _ layerIdx As Integer _ ) As Boolean |
Visual C++ |
---|
public: bool IsCoreLayer( int layerIdx ) |
Parameters
- layerIdx
- Type: System..::..Int32
The index of a layer in this CompoundStructure.
Return Value
Returns true if the layer is within the core layer boundary, false if it is in the interior or exterior shell layers.
Remarks
You can change the shell/core layer boundary using SetNumberOfShellLayers(ShellLayerType, Int32).