Sets the number of interior or exterior shell layers.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public void SetNumberOfShellLayers(
ShellLayerType shellLayerType,
int numLayers
) |
Visual Basic |
---|
Public Sub SetNumberOfShellLayers ( _
shellLayerType As ShellLayerType, _
numLayers As Integer _
) |
Visual C++ |
---|
public:
void SetNumberOfShellLayers(
ShellLayerType shellLayerType,
int numLayers
) |
Parameters
- shellLayerType
- Type: Autodesk.Revit.DB..::..ShellLayerType
If ShellLayerType.Exterior set the number of exterior shell layers (or top shell layers for a roof, floor, or ceiling type).
If ShellLayerType.Interior set the number of interior shell layers (or bottom shell layers for a roof, floor, or ceiling type).
- numLayers
- Type: System..::..Int32
The number of layers to be in the specified shell.
Remarks
Exceptions
See Also