Creates a fascia along a reference.
Namespace: Autodesk.Revit.CreationAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public Fascia NewFascia( FasciaType FasciaType, Reference reference ) |
Visual Basic |
---|
Public Function NewFascia ( _ FasciaType As FasciaType, _ reference As Reference _ ) As Fascia |
Visual C++ |
---|
public: Fascia^ NewFascia( FasciaType^ FasciaType, Reference^ reference ) |
Parameters
- FasciaType
- Type: Autodesk.Revit.DB.Architecture..::..FasciaType
The type of the fascia to create
- reference
- Type: Autodesk.Revit.DB..::..Reference
A planar line or arc that represents the place where you want to place the fascia.
Return Value
If successful a new fascia object within the project, otherwise nullNothingnullptra null reference (Nothing in Visual Basic).
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown if the fascia type does not exist in the given document. |