Inserts a (key,info) pair into Export font table.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2014
Syntax
C# |
---|
public void Add( ExportFontKey exportFontKey, ExportFontInfo exportFontInfo ) |
Visual Basic |
---|
Public Sub Add ( _ exportFontKey As ExportFontKey, _ exportFontInfo As ExportFontInfo _ ) |
Visual C++ |
---|
public: void Add( ExportFontKey^ exportFontKey, ExportFontInfo^ exportFontInfo ) |
Parameters
- exportFontKey
- Type: Autodesk.Revit.DB..::..ExportFontKey
The export font key to be added.
- exportFontInfo
- Type: Autodesk.Revit.DB..::..ExportFontInfo
The export font info to be added.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | The key already exists in the table. |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |