A creator that will be called for the pane if the FrameworkElement is not set.
Namespace: Autodesk.Revit.UIAssembly: RevitAPIUI (in RevitAPIUI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2018
Syntax
C# |
---|
public IFrameworkElementCreator FrameworkElementCreator { get; set; } |
Visual Basic |
---|
Public Property FrameworkElementCreator As IFrameworkElementCreator Get Set |
Visual C++ |
---|
public: property IFrameworkElementCreator^ FrameworkElementCreator { IFrameworkElementCreator^ get (); void set (IFrameworkElementCreator^ value); } |
Remarks
This is more dynamic in nature and allows for embedding things like
WebBrowser controls that cannot be cached for reuse in each pane invocation
but rather needs creating each time.